POTV - Your vaping community

Wanting to join the rest of our members? Why not sign up today!

Register

VooPoo Drag "check atomizer" *HELP PLEASE*

Discussion in 'Everything ECigs' started by Soarific, Oct 16, 2018.

  1. Soarific

    Soarific Initiate

    Joined:
    Oct 4, 2018
    Messages:
    35
    Likes Received:
    10
    Hi everyone,

    This is my first mod and it has been working fine. I just put in a new coil like I always do, cleaned up the tank with water etc and dried it all out, now when it is screwed on it reads 9.99 ohms and wont let me fire it, when i press the fire button it says "check atomizer"

    I tried screwing it off and wiping the gold screw thing but nothing changes

    I need help :(
     
  2. Sam's Vape Reviews

    Sam's Vape Reviews Achiever

    Joined:
    Mar 10, 2017
    Messages:
    4,926
    Likes Received:
    4,905
    Have you tried putting a different coil in and trying it or trying the tank on a different mod?
     
  3. MrDJ

    MrDJ Legend

    Joined:
    Apr 4, 2015
    Messages:
    19,220
    Likes Received:
    11,992
    faulty coil or not screwed in the tank properly. take it apart and try again.
     
  4. DjDoc

    DjDoc Achiever

    Joined:
    Aug 5, 2015
    Messages:
    1,940
    Likes Received:
    837
    Take tank off then press fire button to make sure drags awake, attach tank while screens awake.

    It should say new coil yes or no?
     
  5. Soarific

    Soarific Initiate

    Joined:
    Oct 4, 2018
    Messages:
    35
    Likes Received:
    10
    Yeah I just tried another new coil of the same kind and that read the ohms fine, thats annoying that a brand new coil doesn't work... thanks for the help though :)
     
    • Like Like x 2
  6. Soarific

    Soarific Initiate

    Joined:
    Oct 4, 2018
    Messages:
    35
    Likes Received:
    10
    That worked mate, thanks a lot :)
     
    • Like Like x 3
  7. Cher

    Cher New Member

    Joined:
    Jan 4, 2020
    Messages:
    2
    Likes Received:
    0
     
  8. Cher

    Cher New Member

    Joined:
    Jan 4, 2020
    Messages:
    2
    Likes Received:
    0
    I had the same issue, I found that if I screw the atomizer into the base first and then add the tank, it didn't happen.
    hth!
    Cher

     
  9. Josie1169x

    Josie1169x New Member

    Joined:
    Apr 4, 2020
    Messages:
    1
    Likes Received:
    0
    Im having the same issue
     
  10. MrDJ

    MrDJ Legend

    Joined:
    Apr 4, 2015
    Messages:
    19,220
    Likes Received:
    11,992
    as i said previously. try above.

    and welcome to the planet.
     

Share This Page