POTV - Your vaping community

Wanting to join the rest of our members? Why not sign up today!

Register

Need some help with a YFTK 'Venom X' mech squonker

Discussion in 'Mech Mods' started by tomhirvin, Nov 30, 2017.

  1. tomhirvin

    tomhirvin Postman

    Joined:
    Apr 30, 2014
    Messages:
    193
    Likes Received:
    25
    I recently got one of these and am thinking of sending it back for various reasons I will go into. Before I do I wanted to ask your technical advice to see if there is anything I can do to modify it. Sending things back to China is always fraught with risk and also takes ages so if I can get it to work properly I will.

    I am running it with a new and fresh 20700 battery. 24g parallel single coil coming out at 0.25ohms. This equates to about 70w. When I press the fire button I get nothing for about two seconds and then it fires very weakly. Like the hit from a 12w cigalike.

    This is when it does fire. Often it decides not to. I have checked the battery contacts and they are fine. The atty is making contact with the 510 and it fires as you would expect on another mod I have. There also doesn't appear to be much voltage drop either. The problem appears to be the switch.

    I have worn down the delrin actuator it came with and also another one I bought in a day or so. I thought it was because of how hard I was pressing down but now I think they have actually melted slightly. The metal that makes contact with the fire button and is pushed down onto the 510 gets extremely hot very quickly. I tried a metal actuator (from an old vaporshark) and within a few seconds of firing it burns your fingers. There is also a burnt carbon build up on the fire button plate that makes contact with the 510 to fire it.

    So my question is, what could be the problem here? I doubt the genuine article is this shite and they look identical. Contacts are stainless steel by the looks of things.
     
  2. Bazz_74

    Bazz_74 Postman

    Joined:
    Aug 9, 2014
    Messages:
    630
    Likes Received:
    322
    I'm not familiar with that particular mod, however in my experience most cloned mech squonkers can be improved vastly by fitting a mod maker 510 and swapping the contacts out for copper sheet trimmed to size, a fairly easy job for even the dimmest of fabricators (i.e. me!) and will probably cost less than the return postage.

    I've come to view most of these clones as an enclosure only.
     
    • Like Like x 1
  3. tomhirvin

    tomhirvin Postman

    Joined:
    Apr 30, 2014
    Messages:
    193
    Likes Received:
    25
    Cheers Bazz. I'm on it. Have access to a school DT lab so shouldn't be too hard! Thanks, Tom
     
  4. Rob

    Rob Super Moderator
    Staff Member

    Joined:
    Aug 18, 2013
    Messages:
    14,722
    Likes Received:
    13,725
    Hi Tom @tomhirvin :)
    I was speaking about this very thing only yesterday with @gazlynn when discussing the Pros and Cons of potentially getting a Real One for myself. Gaz mentioned that there appears to be a lag between hitting the fire button and then the Mod Firing and that's on the real deal!

    Maybe Gaz will drop by and pass on words of wisdom? ;)
     
  5. gazlynn

    gazlynn Moderator
    Staff Member

    Joined:
    Dec 7, 2015
    Messages:
    2,095
    Likes Received:
    2,291
    Hi Tom

    There where issues with the first batch of Venoms regarding a brass part that needed changing to a SS version as it was quite weak with the brass part...

    20171207_105555.jpg

    I had slight issues with the throw from the button and had to put some insuating tape on the back of the delrin button so it contacted quicker with the plate. I would check that the firing pin is in the correct position...

    20171202_121142.jpg

    Mines has never got warm and is a cracking piece of kit so can't help on other issues you're having but obviously something isn't right there.

    Please don't take this the wrong way but I've no experience with the cloned version though.

    cheers

    Gaz
     
  6. tomhirvin

    tomhirvin Postman

    Joined:
    Apr 30, 2014
    Messages:
    193
    Likes Received:
    25
    [​IMG]

    [​IMG]

    They look uncannily similar. It's definitely a clone of the newer one as there is only SS and no brass anywhere. I wonder if the petal on the genuine one is silver or plated silver. Mine oxidises almost immediately which is why it isn't firing properly.
     
  7. tomhirvin

    tomhirvin Postman

    Joined:
    Apr 30, 2014
    Messages:
    193
    Likes Received:
    25
    I forgot to thank you for your reply!
     
  8. gazlynn

    gazlynn Moderator
    Staff Member

    Joined:
    Dec 7, 2015
    Messages:
    2,095
    Likes Received:
    2,291
    Hmmm...

    I'm at a loss then with what's going on with yours m8...

    Not much else to them right enough

    cheers

    Gaz
     

Share This Page