POTV - Your vaping community

Wanting to join the rest of our members? Why not sign up today!

Register

Gone back to my mechs- normal heat?

Discussion in 'Mech Mods' started by conanthewarrior, Jun 2, 2019.

  1. conanthewarrior

    conanthewarrior Achiever

    Joined:
    May 17, 2015
    Messages:
    2,757
    Likes Received:
    1,585
    Hi everyone, today I decided to maintain my mechs, and also did some builds with RDA's I haven't used in a while specifically for me mechs.

    I went for a SS SMPL clone first, with a mutation x V4S on top. I built to around 0.2, simple dual coils as I find they ramp up faster and give a nicer vape.

    The thing is, the mod feels rather warm- this is mainly at the RDA end so I wouldn't worry, but have noticed the button getting hot sometimes.

    I am using Sony VTC5A's due to the resistance, and extra headroom compared to HE4's and 25R's.

    I just wanted some clarification that this is normal before I continue to use it, I haven't used my mechs properly in around a year so have forgotten the quirks of each mod. This one is a good quality clone and was used a lot in the past.

    Any advice would be much appreciated.
     
  2. John R

    John R Veteran

    Joined:
    Mar 18, 2018
    Messages:
    5,401
    Likes Received:
    4,737
    SS mods seem to suffer from hot button issues from what I've seen of others, your build is within the limits of a VTC5a so just sit it down to cool down if it's uncomfortable in the hand after a few toots :)
     
    • Like Like x 3
  3. mattyk2010

    mattyk2010 Veteran

    Joined:
    Aug 6, 2016
    Messages:
    8,112
    Likes Received:
    8,210
    @John R is spot on and the smpl switch Is not made for low builds so even my copper one gets a warm button at .2 but its nothing to worry about I still use mine like that although if I go up to .26 the button stops getting warm
     
    • Like Like x 4
  4. oldhippydude

    oldhippydude Veteran

    Joined:
    Apr 6, 2014
    Messages:
    5,001
    Likes Received:
    3,705
    I Love my smpl clones but I do build high res.
    I would grab another of your mechs better suited to 0.2 ohm.
    Why vape with a warm button, when you have better mechs for the job (even I do and I do not even need one)
     
    • Like Like x 2
  5. conanthewarrior

    conanthewarrior Achiever

    Joined:
    May 17, 2015
    Messages:
    2,757
    Likes Received:
    1,585
    Thank you all for your help.

    I had a bit of a wobbly weekend, so digging out the mech collection probably wasn't the best idea at the time. However I checked it over this morning, and used it along with a Wotofo phantom as my take out mods for the day. @oldhippydude I agree with you there, I wasn't thinking very straight though when I made this thread.

    It's been a long time since I have used a mech as my ADV- I think I will carry on doing this from time to time as it's a lot more comfortable and inconspicuous than most of my regulated mods.
     
    • Like Like x 3
  6. EmbraSewerRat

    EmbraSewerRat Veteran

    Joined:
    Aug 29, 2014
    Messages:
    5,141
    Likes Received:
    3,483
    So what did you put on the Phantom laddie?? Was it a similar outcome? My SMPL clone is now a dust magnet as it can't deal with my preferred mech builds. My Phantom wasn't much better if memory serves.

    Still at least you have learned the lesson AND without anything untoward happening. Win.
     
  7. smplmind

    smplmind Postman

    Joined:
    Jul 22, 2016
    Messages:
    595
    Likes Received:
    282
    I run my SMPL clones at high Ohms Sykline at 0.9 and Nextiny at 0.7, for my drop I use a broadside but even that is 0.25 Ohm which for me is low. Although I'm sure in years gone by I have had the SMPL at 0.25 and not had a warm switch but I've never used those as low as 0.2.
     
  8. conanthewarrior

    conanthewarrior Achiever

    Joined:
    May 17, 2015
    Messages:
    2,757
    Likes Received:
    1,585
    I've kept the Phantom paired with a Wotofo Lush since I bought it. I really like the phantom, I use it with the standard 510 connection, not the hybrid style. Never have noticed any warmth issues with it, even on builds that are pushing things.

    Definitely. I didn't realise at the time I wasn't with it, only through friends and family. I wouldn't usually use a mech mod if I knew I was under the influence of anything that had impaired me.
     
    • Like Like x 1

Share This Page