POTV - Your vaping community

Wanting to join the rest of our members? Why not sign up today!

Register

Odin DNA250c 510 loose

Discussion in 'Temperature Controlled Vaping' started by weerabmc, Jul 31, 2020.

  1. weerabmc

    weerabmc Initiate

    Joined:
    Nov 5, 2017
    Messages:
    14
    Likes Received:
    12
    Good Morning Everyone,
    Hope I don't waken anyone up. My 5year old decided to waken me at 6:15 this morning. So decided to get up with him an hour and a half before my alarm goes of for work. Knackered so hope this all makes sense and is in the right forum. Please move if I'm not.

    Want to see if anyone has or knows how to take this apart. Basically believe I have a loose 510. Was enjoying the Replay option a lot. But now unable to save puff as it hits temperature protect everytime. In Atomiser mode when I measure Ohm's they jump. In Diagnostics mode the Ohm's are where they should be 0.27.

    So I had my mod in work sitting on a shelf about 3ft high above a concrete floor (with my mobile). Found them lying on the floor and of course no-one knows how it fell. Ever since I have been having issues with Ohm's jumping from 0.4 to 0.5. I have taken apart, cleaned thoroughly and replaced new coils about 5times in my Zeus X. So last night had the chance to get the Mod onto Escribe to do a wee investigation. Been through all connections on the Zeus. What I found though was if I tug on the rta the ohms come down to 0.28. press on it the ohms go to 0.6. I have got up this morning and put my Riftcore Duo on to it as this rta has fixed ohms, as it uses plates instead of coils. Ohm's jumping around on this to.

    Like to think I'm a bit experienced in vaping. My last device was a DNA200 which I tightened the 510 on a few times. Had it for about 3 years. Loved it. But a leaky Vandy Vape Triple RTA fried my board. So decided to purchase the Odin. Got it as new from an eBay seller about 2,months ago. And been really liking it since. Never thought a 2 battery mod would do me. I use SS in my Zeus and have taken Ohm's reading while cold.

    Hope someone can help. But scared to remove screws incase the whole mod springs apart leaving me modless.

    Time to get ready for work. Forgive me if I don't reply immediately. Will check my fone through the day though and reply when I can.

    Rab
     
    • Like Like x 1
  2. TMBNotes
  3. Arawn1975!

    Arawn1975! Achiever

    Joined:
    Oct 25, 2019
    Messages:
    1,363
    Likes Received:
    900
    • Like Like x 2
  4. KytanDale

    KytanDale Mod Maker

    Joined:
    May 30, 2019
    Messages:
    685
    Likes Received:
    1,093
    I've not had this mon in service yet, can't really say if easy to service if you don't have the experience. I can take a look at the mod if willing to send it to me.
     
    • Like Like x 2
  5. Vapable
  6. nwhornet

    nwhornet Legend

    Joined:
    Feb 22, 2016
    Messages:
    11,221
    Likes Received:
    10,372
    There's three screws that look like they hold the top on. 510 looks to be held in place by the top section. Not taking mine apart to find out though .
     
    • Like Like x 2
  7. weerabmc

    weerabmc Initiate

    Joined:
    Nov 5, 2017
    Messages:
    14
    Likes Received:
    12
    Cheers for the replys everyone. Thank KytanDale for offer. Nwhornet had been thinking about them 3 screws. Was kinda hoping someone would voluntarily loosen theirs first and make a wee video. Could make ya famous lol. Just joking. Gonna give it a wee go tonight. Pray I don't regret it.
     
    • Like Like x 1
  8. nwhornet

    nwhornet Legend

    Joined:
    Feb 22, 2016
    Messages:
    11,221
    Likes Received:
    10,372
    Most DNAs I've come across have been relatively easy to work on. \just take your time & take photos so you don't end up with a spare screw. Given that it was dropped with an attie on you can use a toothpick to check the 510 hasn't got stuck. It should move up & down with a little resistance from the spring.
     
    • Like Like x 2
  9. weerabmc

    weerabmc Initiate

    Joined:
    Nov 5, 2017
    Messages:
    14
    Likes Received:
    12
    Thanks nwhornet. I got midway through taking the top of then bottled out. Took a couple of pics. Wasn't as easy as my last mod, was about to loosin the first screw at the battery connection (it's screwed into the top), and I kind of felt a presence telling me 'Dont go any further dumbo'. So screwed the 3 screws back on top.lol

    Then got a tooth pick and pushed the 510 it seemed fine, so ran the pick around it to make sure no dirt or anything had got in. Now the Ohms are back to being steady again. Phew.

    Cheers for your help. View attachment 225058 View attachment 225057 View attachment 225059 IMG_20200731_172137.jpg
     
    • Like Like x 3

Share This Page