POTV - Your vaping community

Wanting to join the rest of our members? Why not sign up today!

Register

Drag X RTA misreading ohms

Discussion in 'Rebuildable Mods and Devices' started by ScottishDuck13, Sep 24, 2020.

  1. ScottishDuck13

    ScottishDuck13 Postman

    Joined:
    Mar 7, 2017
    Messages:
    419
    Likes Received:
    165
    Hi guys,

    I usually use only rebuildables for the last few years but just wanted a small handheld device so I got the Drag X as it looks so damn nice and got the RTA deck pod with it. So far I have tried 3 different coils/builds and cannot get it to work properley and today have just realised why. When I have the VM1 stock coil in, its 0.3ohms. When I swap it over to my RTA pod, it still reads at 0.3ohms. I have put multiple builds onto ohm readers and DNA devices, all read them accurately, the latest one is 0.45ohms.

    When I add the 510 adaptoer and use the pod on my DNA mod, it reads at 0.45 and vapes as it should, however remove from there and put back on my Drag X and it reads it at 0.3 again?! Its like its stuck with what the last stock coild read at.

    I have turned it off/on, changed batteries, cleaned the connections, made sure nothing looked out of place and even tried re-doing the Firmware update even though I did that the day I got it.

    Right after the firmware update it finally read my RTA pod at 0.45, but then I took it off, put it back on and its back to 0.3?! I sat for 5mins just pulling the pod off/on to force re-reads and once during the whole time it read at 0.45 like it should.

    I have to say the first stock coil I tried on it (the VM6 was surprisingly fantastic!

    Any ideas guys? :(
     
  2. TMBNotes
  3. nwhornet

    nwhornet Legend

    Joined:
    Feb 22, 2016
    Messages:
    11,442
    Likes Received:
    10,693
    Are you using the Voopoo RTA or a third party version. The VXV version I have is erratic on both Drag X & Argus but the Voopoo one is fine. Also are you in RBA or Smart mode?
     
  4. iqon

    iqon Achiever

    Joined:
    Mar 3, 2018
    Messages:
    4,718
    Likes Received:
    3,158
    Daft question I know, Does it make a difference in rba mode ?
     
  5. ALD Group
  6. nwhornet

    nwhornet Legend

    Joined:
    Feb 22, 2016
    Messages:
    11,442
    Likes Received:
    10,693
    Stops max watts limit based on resistance. Personally not had a problem running in RBA mode except with the VXV RDTA but that's a pain on anything.
     
  7. iqon

    iqon Achiever

    Joined:
    Mar 3, 2018
    Messages:
    4,718
    Likes Received:
    3,158
    I know that !!! but has OP got it in rba mode. ?
     
  8. ScottishDuck13

    ScottishDuck13 Postman

    Joined:
    Mar 7, 2017
    Messages:
    419
    Likes Received:
    165
    Thanks for the replies guys.

    Yes it's the official Voopoo RTA pod. (the whole pod RTA version, not just the little RBA coil).

    And yes I was trying it in RBA mode although I did try it in Smart aswell just to see... Exactly the same
     
    • Thank Thank x 1
  9. ScottishDuck13

    ScottishDuck13 Postman

    Joined:
    Mar 7, 2017
    Messages:
    419
    Likes Received:
    165
    Please see the 2 pictures below.

    The first one shows the stock pod with the VM1 coil on the Drag X, correctly showing ohms of 0.3. Then the RTA pod on my DNA mod correctly showing the ohms at 0.425

    Then the 2nd picture is me swapping the pods round. So the DNA mod correctly shows the stock pod VM1 coil at 0.294, however the Drag X still showing the same 0.3ohm as before evn with the RTA pod on it.

    IMG_20200925_091808.jpg IMG_20200925_091855.jpg
     
  10. memzey

    memzey Postman

    Joined:
    Sep 24, 2018
    Messages:
    500
    Likes Received:
    438
    I know nothing about these pods and coils but I am very glad to see that there is another member of the Triade Users Club here. Love that mod, knocks all my others into a cocked hat.
     
    • Like Like x 1
  11. ikes

    ikes Initiate

    Joined:
    Jan 13, 2020
    Messages:
    17
    Likes Received:
    14
    I sold my Vinci X and Drag X because of this. Bought them as MTL or single DL mods and they couldn't read correct ohms at least for once... Tried different 510 adapters, official and other RBA coils, software update, brand new batteries, different wires, ten or more RTAs, more RDAs. Nope; every MTL coil 0.85 or 1.4 ohm, every DL coil 0.45... Same chip same behaviour.
     
    • Like Like x 1
  12. ScottishDuck13

    ScottishDuck13 Postman

    Joined:
    Mar 7, 2017
    Messages:
    419
    Likes Received:
    165
    Thats shite! It annoys me how well they perform with the VM6 stock coils. They have almost a perfect vape for my taste, I just hate buying coils, partly stindgy but i love the hobbyist aspect of rebuildables.

    I actually emailed Voopoo support, they asked me to send a demo video showing the fault, so I did, you can see it here:


    But got a response this morning from @VOOPOO and know what there answer to a mod misreading ohms by over 0.1 was?...

    "It's normal, for your info, there exists a reading allowance range"

    They say they passed it onto their tech team but if thats their attitude and knowledge then thats ridiculous.
     
    • Like Like x 2

Share This Page