POTV - Your vaping community

Wanting to join the rest of our members? Why not sign up today!

Register

Chi Megan Problems

Discussion in 'Rebuildable Mods and Devices' started by Greebs, Aug 15, 2014.

  1. Greebs

    Greebs Postman

    Joined:
    Mar 10, 2014
    Messages:
    182
    Likes Received:
    10

    This is an ohms meter where I can screw the atty on to or test the battery power. It's a vaping outlaws one
     
  2. Mr.Motivapr

    Mr.Motivapr Achiever

    Joined:
    Feb 5, 2014
    Messages:
    3,943
    Likes Received:
    999
    Test your battery then mate, if it's measuring around 4.2 then it's charged and the mod is the issue...
     
  3. Mr.Motivapr

    Mr.Motivapr Achiever

    Joined:
    Feb 5, 2014
    Messages:
    3,943
    Likes Received:
    999
    Also when it's all assembled is everything snug? No battery rattle etc?
     
  4. Greebs

    Greebs Postman

    Joined:
    Mar 10, 2014
    Messages:
    182
    Likes Received:
    10
    Battery is firing fine in the mod and no battery rattle when assembled
     
  5. Greebs

    Greebs Postman

    Joined:
    Mar 10, 2014
    Messages:
    182
    Likes Received:
    10
    If it helps at all. When it does fire, the dripper is getting really hot
     
  6. Mr.Motivapr

    Mr.Motivapr Achiever

    Joined:
    Feb 5, 2014
    Messages:
    3,943
    Likes Received:
    999
    The battery is firing fine?
    I thought it wasn't or am I missing something lol?

    Or is it fixed after cleaning the bottom??
     
  7. Greebs

    Greebs Postman

    Joined:
    Mar 10, 2014
    Messages:
    182
    Likes Received:
    10
    It might not be the mod after testing the battery a couple of times inside the mod on the meter it reads 4.01V everytime I fire it
     
  8. Mr.Motivapr

    Mr.Motivapr Achiever

    Joined:
    Feb 5, 2014
    Messages:
    3,943
    Likes Received:
    999
    So very little vapour production but very hot? Sounds like a short mate.

    But you say the atty is measuring 0.4? Therefore no short, very odd!
     
  9. Greebs

    Greebs Postman

    Joined:
    Mar 10, 2014
    Messages:
    182
    Likes Received:
    10
    Just tested the dripper and it's now reading 1.01 ohms so that may be the problem as it was reading .4
     
  10. Mr.Motivapr

    Mr.Motivapr Achiever

    Joined:
    Feb 5, 2014
    Messages:
    3,943
    Likes Received:
    999
    So that means battery is pretty well charged.

    Is the coil glowing as normal?

    Legs not glowing etc?
     

Share This Page