POTV - Your vaping community

Wanting to join the rest of our members? Why not sign up today!

Register

NextGen Clone Issues

Discussion in 'All Things Mesh and Genesis' started by Big Kev, May 25, 2015.

  1. tinyredpostbox

    tinyredpostbox Postman

    Joined:
    Jun 26, 2014
    Messages:
    906
    Likes Received:
    169
    perhaps a temporary fix could be packing out the diameter of the insulator then.

    i had instant success following this guy's build tutorial

    https://www.youtube.com/watch?v=u1zqSOPmOzo


    i used 400 mesh for all of the wick, and have had great results using 60vg at up to around 15w. pulse the coil to start with at low wattage until the hotspots are gone, i have burned out kanthal quite a few times when forgetting to drop the wattage for pulsing. it just burns out like fuse wire!
     
    • Thank Thank x 1
  2. Fopster

    Fopster Postman

    Joined:
    Jul 16, 2014
    Messages:
    575
    Likes Received:
    166
    I've not seen my Pal's one, but from what he's described the 510 pin is pretty shoddy and spins freely/rocks, plus the positive screw is poor too.

    He's still not fixed it, but I'd imagine his main issue it to do with the insulator.

    Sorry I can't be of any more help!
     
    • Thank Thank x 1
  3. Big Kev

    Big Kev Achiever

    Joined:
    Apr 13, 2014
    Messages:
    1,308
    Likes Received:
    284
    Cheers for that mate, I'll have a watch later on.
     
  4. Big Kev

    Big Kev Achiever

    Joined:
    Apr 13, 2014
    Messages:
    1,308
    Likes Received:
    284
    Same as mine then, cheers for the info mate, at least it's not me being a moron, as per normal, by the looks of it.
     
    • Like Like x 1
  5. Fopster

    Fopster Postman

    Joined:
    Jul 16, 2014
    Messages:
    575
    Likes Received:
    166
    Hi Mate,

    How've you got on with your ticket with Fasttech? Are they sending a replacement?
     
    • Thank Thank x 1
  6. Big Kev

    Big Kev Achiever

    Joined:
    Apr 13, 2014
    Messages:
    1,308
    Likes Received:
    284
    They've said they'll be sending out a replacement base, although it looks like they're going to send a new NextGen, according to my order page, so I hope to have it in a few weeks.

    Cheers mate.
     
  7. tinyredpostbox

    tinyredpostbox Postman

    Joined:
    Jun 26, 2014
    Messages:
    906
    Likes Received:
    169

    you might be lucky to get an entire new one, but when i had a problem with a top cap for a mod, they added what looked like an entire replacement to my orders, but it was just the top cap they sent out.
     
    • Thank Thank x 1
  8. Fopster

    Fopster Postman

    Joined:
    Jul 16, 2014
    Messages:
    575
    Likes Received:
    166
    Nice one, fingers crossed it does the trick
     
    • Thank Thank x 1
  9. Big Kev

    Big Kev Achiever

    Joined:
    Apr 13, 2014
    Messages:
    1,308
    Likes Received:
    284
    As long as I can actually get the thing working, I'm not too bothered actually. I suppose I've been pretty lucky with FT, as this is the only real problem that I've had with their gear.
     
  10. 9668harry

    9668harry Achiever

    Joined:
    Feb 24, 2014
    Messages:
    1,434
    Likes Received:
    519
    I got one from FT the other day. Fortunately the insulator/pos pin is fine on mine, rock solid in fact. You must have just got a duff one. Hopefully the one they send you will be tip top. I'm quite impressed with mine tbh. Couple of failed mesh wick attempts, but i seem to have got a decent working setup in it at the minute. Works well.


    Sent from my iPhone using Planet of the Vapes
     

Share This Page