POTV - Your vaping community

Wanting to join the rest of our members? Why not sign up today!

Register
  1. The POTV Charity Fundraising Event for 2019 is go! Check out the prizes and make your donations here.
    Dismiss Notice

DIY Box Mod - Auto fires after fire switch is pressed

Discussion in 'All Things Mod Making' started by Amrian, Apr 5, 2019.

  1. Amrian

    Amrian New Member

    Joined:
    Apr 5, 2019
    Messages:
    3
    Likes Received:
    2
    Just as the title says, the box mod will sometimes auto fire or continue to fire after the fire switch is pressed. I'm "pretty sure" it's the fire switch not disconnecting after being pressed (so I bought a new/different one - waiting for it to ship). No voltage is being passed through when the switch is decompressed. I'm really hoping it's just a faulty fire switch but wanted to drop the concern in here to see what you guys think. It's full on firing sometimes (at least twice so far) causing the coil to burn and me having to take out the batteries as fast as I can. I use a series -- regulated board from Big Al.

    Thanks for any tips and helpful advice!
     
  2. shale84

    shale84 Postman

    Joined:
    Sep 8, 2016
    Messages:
    548
    Likes Received:
    569
    Either switch is faulty or button stucks
     
    • Like Like x 2
  3. Amrian

    Amrian New Member

    Joined:
    Apr 5, 2019
    Messages:
    3
    Likes Received:
    2
    That’s what I’m thinking. Didn’t know if I may have overlooked something. Thank you for your input, I’m hoping once I get this new switch it won’t do it anymore. Going to add a ribbon so I can get the batteries out ASAP in case it’s not.
     
  4. shale84

    shale84 Postman

    Joined:
    Sep 8, 2016
    Messages:
    548
    Likes Received:
    569
    Do you feel that button stucks or stay down in firing position?
     
  5. shale84

    shale84 Postman

    Joined:
    Sep 8, 2016
    Messages:
    548
    Likes Received:
    569
    And send a pic of switch,I may have one spare
     
  6. Amrian

    Amrian New Member

    Joined:
    Apr 5, 2019
    Messages:
    3
    Likes Received:
    2
    I actually already bought one! Thank you though, that’s a very generous offer. It doesn’t feel like it sticks, at least 90% of the time. I don’t have the mod with me ATM but I’ll take a pic later on tonight. I’ve tried to replicate the “sticking” with it powered off but no luck. It almost seems like the mechanism inside the switch is faulty. Going to keep a close eye on it when I put in the new switch and if it does it again something else is the issue and I’m just going to scrap it into a new mod with a new board. As long as it doesn’t auto fire on its own without the switch being pressed then it should just be the switch.
     
    • Like Like x 2

Share This Page